GIS & Watershed Analysis

Intermediate

Class Materials and Curricula Developed by:
Joshua H. Viers, Ph.D.
Lab Exercise 1:
Spatial Analyst, Raster Data Analysis, DEMs, and more...

- **Problem Statement:** Using ArcMap in ArcGIS, determine the probable nesting locations of the rare marbled murrelet (*Brachyramphus marmoratus*) in the Navarro River watershed. The marbled murrelet is a secretive bird, but it is thought to make its nests in old growth forests on steep (> 20°), west-facing slopes within 35 km of the ocean at or around the 150m elevation.
What data are necessary to address the problem at hand?
• **Hint:** This task will require the development of a Data View object, the addition of vector and raster data Layers to the Map Document, and advanced queries.

• **Synoptic Procedures:** Create a new Document and assign Data Frame Properties (e.g., units=meters). Add NAV10M layer. Generate HILLSHADE, SLOPE and ASPECT grids; load COASTDISTANCE and OLDGROWTH grids.

• Query grids to determine probable nesting locations based on outlined habitat parameters.

• Display resulting habitat patches draped over the DEM with HILLSHADE as a brightness theme and elevation contours overlaid.
Start ArcMap.

Start ArcMap 9.0 by initiating 
Windows Start ⇒ Programs ⇒ ArcGIS ⇒ ArcMap
Save the ArcMap Document.

- Save your Map by using the File Pull-down menu and selecting Save.
- ① Give it a File Name in the ..\unex\ directory that you will remember (e.g., jhviers.mxd).
• Set the Data Frame Properties.

① Set the Data Frame Properties by selecting from the View Pull-down Menu.

② Set the Name to Navarro Watershed Frame. Set the Map Units to meters.
• **① Add the Spatial Analyst Extension.** Add the Spatial Analyst Extension by selecting the Tools → Extensions Menu item. Check the Spatial Analyst box and select **Close**.

• **② Notice the toolbar, with a menu, a combo box, and two new tools?**
• ① Add the DEM Theme. Add the Digital Elevation Model by selecting the File Menu ➔ Add Data item. Navigate to ..\unex\geodata\navarro\ and choose the NAV10M grid theme.

• How can you tell the difference between raster datasets and vector types?
• **Change the NAV10M legend.** Change the NAV10M layer legend by right-clicking Layer ⇒ Properties item.

• ① Notice that the Source Tab has cell Size, data type, and file location, and what else?

• ② Choose the Symbology Tab and find a Stretched Color Ramp that approximates “Elevational Banding”

• ③ Select OK.
• Q1 - There is an alternate way of getting to the Data Layer Properties Form. What is it?

• Q2 - There is an alternate way of changing the Data Layer Legend ramp colors. Can you find it?

• Q3 - What about a quick rename of the Data Layer?

• Q4 - How do you turn all of the layers ‘off’?

A1 - Double-click the Layer Item.
A2 - Click on the color ramp and choose.
A3 - Click on the name twice, but slowly.
A4 - Hold down the Control key
Create a Histogram of the Navarro DEM. Create a Histogram of NAV10M by making the Raster Layer the *selected item* in the Spatial Analyst and clicking the Histogram Command Button. (Use the Min-Max Stretch for your histogram to match this one).

Examine the resulting distribution. Where would the mean value and standard deviations fall? Is this DEM normally distributed? Will this affect your analyses?

Where can you view the Mean and StdDev graphically?
Data Layer Properties *Classification* is often a more informative method of examining the distribution of Raster Data. Ramp Layer by Class, select the ‘Classify…’ button to access.
• Set up Spatial Analysis Parameters. Set up the parameters for Spatial Analysis by selecting the Spatial Analyst menu ➔ Options item. ① Change the Analysis Extent to “Same as NAV10M”. ② Set Analysis Cell Size equal to “Same as NAV10M”.

• Look at the other menu options. Why would you use any of the other options?

• ③ Set the Working Directory to ..\unex\temp\ in the General Tab.
• **Generate a SLOPE Grid of the Navarro DEM.** ① Generate a grid representing SLOPE by making the NAV10M grid by using the Spatial Analyst ⇒ Surface Analysis ⇒ Slope item.

② What measure is required for the analysis? Percent slope or degree slope?

③ Save as a permanent raster grid named SLOPE in the ..\unex\temp directory.

• **Change the Legend Value Classification to Standard Deviation Type.**

• **Examine the Slope of the Navarro DEM.** Does it seem representative of a coastal watershed?
• What is the distribution of Degree Slope in the Watershed?
• What does it tell you about the watershed?
• Can you achieve a similar histogram by using the Layer Properties form? Which is more informative?
• Generate an ASPECT Grid of the Navarro DEM. Generate a raster grid representing ASPECT by selecting the Spatial Analyst → Surface Analysis → Aspect item.

• Examine the Legend associated with Aspect of Navarro DEM. What are the values depicting?

• What value is used for flat areas? Is there anything peculiar about the output? Make flat areas black and examine the output up close.
Does the Slope grid show similar terracing?
• Examine the distribution the ASPECT raster data.
• What pattern do you notice?
• Can you take a mean value of ASPECT?
• Is there a way to handle these data in a linear fashion?
• Generate a HILLSHADE Grid of the Navarro DEM. ① Generate a grid representing HILLSHADE by selecting the Spatial Analyst ➔ Surface Analysis ➔ Hillshade item.

• Use ArcGIS Help to determine what the Azimuth and Altitude input parameters are used for and why you might want to change them.

• ② Accept the default parameters of Azimuth = 315° and Altitude = 45° and select OK.

• Set the Transparency of NAV10M to 30% and move above the HILLSHADE raster grid. Notice the draping effect?
• Use Contour Tool to draw contours around the Navarro Estuary. Add the Navarro Estuary vector shapefile (`C:\navarro\nav_estuary.shp`) to the Data Frame, make it visible, and color only the GRIDCODE item = 1.

• Zoom in on the Estuary. Select the Contour Tool (it looks like a thumbprint) from the Spatial Analyst Toolbar.

• Use the tool to draw a contour around the Estuary by clicking on the View Frame once at the edge of the Estuary Polygon.
How close can you approximate the boundary of the Estuary?

This can be done for as many elements that the DEM attributes and structure can support, but it could be very laborious to do the entire watershed. (Note: These are graphic elements and can be edited as such, they are not layers.)
• Create Contours of Navarro DEM for the entire watershed.

  ① Create a Contour data layer of Navarro DEM for the entire watershed by selecting the Spatial Analyst ⇒ Surface Analysis ⇒ Create Contours item.

  ② Use the default values of Contour Interval = 100m and the Base Contour = 0m (we are operating at sea level after all).

  ③ Note: This creates a shapefile named ctour.shp in the working directory and adds it to the Data Frame.
Use the raster Calculator to define Habitat Parameters.

- Create grids that represent the habitat parameters of the Marbled Murrelet by first defining the required Slope parameters.
- Select the Spatial Analyst ☰ Raster Calculator.
- Double click the [SLOPE] data layer in the Layers list.
- Click the > operator button.
- Type in the number 20 so that the : [SLOPE] > 20
- Create the name HABSLOPE, so the syntax is:
  \[ \text{HABSLOPE} = \text{SLOPE} > 20 \]
- Press ✅ Evaluate.
Continue with other Habitat Parameters

- There should be equivalent grids for ASPECT & ELEVATION

- Aspect syntax:
  \[ \text{HABASPECT} = ((\text{ASPECT} > 225) \land ((\text{ASPECT} < 315))) \]

- Elevation syntax:
  \[ \text{HABELEV} = (((\text{NAV10M} > 50) \land ((\text{NAV10M} < 250))) \]

- Load COASTDIST and OLDGROWTH raster data. (\text{..\navarro})

- Do you remember what the criterion is for the distance to coast habitat parameter?

- Use the Raster Calculator with the following equations for Distance to Coast:
  \[ \text{HABDIST} = ((\text{COASTDIST} \leq 35)) \]

- Old Growth syntax, is it needed?
Type in the Syntax to combine the Habitat Parameters.

Is the output raster satisfactory?

What is the difference between using [] brackets for a raster output object and not using them?
Some additional thoughts...

- Examine your output. How do they differ from the Old Growth patches?

- What about the quality of the patches, are there characteristics that might need further investigation?

- What other data layers would be helpful to address this problem statement?

- Why would one use a PERCENT SLOPE versus a DEGREE SLOPE algorithm on a DEM?

- What other habitat related information could be generated from your identified nesting patches?

- If this were a probability exercise, as opposed to presence/absence, which data might you use as a weighting term?

- Why use fixed vs. temporary file names for raster data?
Extra Credit

• Run a Cosine Transform on the ASPECT grid so that values range from -1.0 - 1.0, where 1.0 represents Southwest (Az. 225°).

• Hint: Syntax should look like this... but why?
  SetNull([ASPECT] == -1, Cos(([ASPECT] - 225) div deg))
Extra Extra Credit

- What is the area of each Habitat Patch?
- Hint: you will need to string together a series of commands to isolate each patch and calculate its area.
- Does this raster command sequence make sense? Look up each command in ArcGIS Help.
Lab Exercise #2
FLOWDIRECTION, FLOWACCUMULATION and Hydrologic Spatial Analysis

- **Problem Statement:** Stream Order is an important factor for many hydrologic models in that it helps explain discharge and channel type. Using the ArcView GIS project that you have started, generate a grid of FLOWDIRECTION for the Navarro River watershed. A grid representing flow direction will allow us to determine the direction that water flows; in essence, this is the physical definition of a watershed.

- Using a FLOWACCUMULATION grid, generate a vector arc layer that represents Stream Order for streams with greater than 1 square kilometer in upstream contributing area. The Strahler Stream Order is the most commonly used definition and the method sought after in this exercise.

- A “stream” cell will be defined as having an upstream accumulative area of one square kilometer. This parameter will be determined from a FLOWACCUMULATION grid, adjusted for cell area. The resulting raster linear network will then be assigned a unique value using STREAMLINK and a stream order value using STREAMORDER. The raster data are then converted to a vector shapefile with accompanying attributes and displayed Stream Order.
• Note all of the following procedures are being performed on a depressionless DEM. Prior to initiating any of these algorithms it is important to identify and fill any sinks.

• **Generate the FLOWDIRECTION grid.** Generate the FLOWDIRECTION grid by first looking up the syntax of the request in ArcGIS Help.

• ① Use the Raster Calculator dialog to type the FLOWDIRECTION call by selecting the Spatial Analyst ⇒ Raster Calculator item.

• The FlowDirection process is only successful when the DEM is without any areas of internal drainage, read the Discussions about the Sink and Fill Requests in ArcGIS Help to get more information on this topic.

• ② Use the following syntax:

  \[
  [\text{NAVFLOWDIR}] = \text{FLOWDIRECTION}([\text{NAV10M}])
  \]
FLOWDIRECTION

• What are the output values of the flow direction raster data?
• Are they in accordance with accepted flow direction values?
• Calculate the FLOWACCUMULATION grid. The flow accumulation algorithm is very intensive computationally, thus you may want to take a break.

Choose a breakpoint for the values in the Layer Properties symbology (legend) to show a Classified breakpoint of 10,000. Why? (Hint: The grid values represent the number of cells flowing into it.)

• Examine the data theme in the data frame; it is likely that you will have to Zoom-In quite a bit to see the values greater than 10,000 cumulative cells.

• What do these cells appear to represent?
• Query the Navarro Flow Accumulation grid to determine cells with more than 1 km² drainage area and create a raster Stream Network.

• ① Query the Navarro Flow Accumulation grid by using the Raster Calculator.

• How many cells constitute 1 km²? Ultimately, use this value when constructing the Query, but take the time to use different breakpoints.

• Which breakpoint do you think fairly represents a stream network? What other data sources might be used to help verify the choice?

• load the vector shapefile of Navarro 100k Hydrography (..\navarro\nav_hydro.shp).

• How do these two datasets compare? Why would you use one versus the other?
• Create a new grid of just the Stream Network with the Flow Accumulation values. To retain the accumulative values of the Navarro Flow Accumulation grid, a new dataset will have to be created.

• The Navarro Stream Network has values of 0 and 1. The Stream Network needs to have NoData values for the non-stream cells to complete our processing.

• The SetNull Request allows for the attribution of values from a grid where values are not null, thus the accumulation values from the Navarro Flow Accumulation grid can be used for attribution of the output grid.

• Use the Raster Calculator with the following syntax:

\[ [NVSTRNET] = \text{SETNULL}([NAVFLOWACC] < 10000, [NAVFLOWACC]) \]
• Create a grid of unique stream segments using STREAMLINK. Using the Raster Calculator, create a STREAMLINK grid using the following calculation:

\[ \text{[NVSTRNET]} = \text{STREAMLINK} ([\text{NVSTRNET2}], \text{[NAVFLOWDIR]}) \]

• This procedure assigns a unique value to each series of connected cells that make up a segment.

• Assign a unique value symbol palette to NVSTRNET3 and view the results of your work.
Embedding Calculations?

For example, embed `SETNULL` within `STREAMLINK`:

```
[rwstrme] = STREAMLINK(SETNULL([navflowacc] < 10000, [navflowacc]), [navflowdir])
```
• Establish STREAMORDER by using the Raster Calculator with the following syntax:

\[
[NVSTRORD] = \text{STREAMORDER}([NVSTRNET3], [NAVFLOWDIR], \text{STRAHLER})
\]

• Look up stream order syntax in help, especially to determine difference in type (Strahler, Shreve).
Convert Raster Streams to Vector Hydrography

- Use the Spatial Analyst Convert Raster to Features on the NVSTRORD raster results to create a vector hydrography network (twice).
  - ① Select PolyLine, Generalize Lines, and name stream_gen.shp
  - ② Select PolyLine, NOT Generalize Lines, and name stream_nogener.shp
- Compare the outputs; notice any differences?
Use Raster Calculator to Create StreamShape

- ① use the STREAMSHAPE command with the WEED option to convert the raster NVSTRORD grid to a vector shapefile.
- Use the ArcGIS Help Spatial Analyst Functional Reference to look up the syntax for STREAMSHAPE.
- Examine differences from previous conversion routines versus the STREAMSHAPE conversion.
Stream Order in Vector Stream Network

- Remember that STREAMSHAPE converted the raster value for our stream network. In this case, these were values of Strahler stream order. These values came across as GRID_CODE.
- The results of this conversion can be shown cartographically in the vector hydrography network.
- Use the Graduated Symbol palette to show the five stream orders in ascending order on the GRID_CODE field.
Is this what you get?
• There is one last step...
  - The conversion routine does NOT bring over the projection file.
  - Define the projection for stream.shp by using ArcToolbox.
  - Select the UTM Zone 10 North NAD27 Datum file.
Extra Credit

- Calculate the mean offset distance of \texttt{nav\_hydro.shp} to the flow path of NAV10m
- Convert \texttt{nav\_hydro.shp} to raster
- Calculate the Euclidean Distance away from \texttt{nav\_hydro grid}.
- Run zonal stats using the stream network grid on the \texttt{nav\_hydro} Euclidean distance
Exercise #3: Spawning Redds and Timber Harvests: a Watershed Based Analysis

- Problem Statement: The relationship between timber harvest practices and habitat quality for salmon is often cited adversely. To help explore the cumulative effect of timber harvests on alteration of spawning redds, we will generate sub-watersheds as units of analysis, incorporate field data, and graph the relationship for recent timber harvests as it relates to spawning activity. GPS field data of salmon spawning locations are provided from UC Davis stream inventories for 2001. Timber Harvest Plans from years 1988-1999 are provided by the California Department of Forestry. Initially, evaluate the number of spawning redds per sub-watersheds created for the Navarro Stream Network. Then evaluate the percentage of watershed harvested of the selected sub-watersheds. Join these two outputs and evaluate them. Conventional wisdom would suggest that sub-watersheds with more redds would have less sustained harvesting activity. There are caveats to this analysis, so be thinking about them as you proceed.
• **Hint:** The primary task is to determine the amount of spawning activity in sub-watersheds in relationship to the amount of Timber Harvest Activity. The extra credit task will require a series of operations that for each redd the embeddedness score for the pool is evaluated against the percent of upstream watershed recently harvested.

• **Synoptic Procedures:** Create watersheds for each of the items in the Navarro Stream Network. Import the GPS data; project them into UTM Zone 10 (NAD27) Projection, snap each redd datum to the Navarro Stream Network, determine the number of redds per sub-watershed, determine the percent of the watershed recently attributed to Timber Harvest Plans, and join the outputs of both. This should result in a single table of sub-watersheds with coho spawning, the numbers of redds, and the percent of the sub-watershed recently harvested.
A bit of review:

- If you haven’t done so already, load the Spatial Analyst Extension and toolbar.
- Load the Navarro DEM (..\navarro\nav10m)
- Make sure your analysis extent, cell size, and working directory are all set in the Spatial Analyst → Options.
  - Extent = NAV10M
  - Cell Size = 10
  - Dir = c:\unex\temp
- Also, it would be good to revisit the following algorithms in ArcGIS help to reinforce what we just accomplished:
  - FLOWDIRECTION
  - FLOWACCUMULATION
  - STREAMLINK
  - STREAMORDER
  - STREAMSHAPE
Generate Discrete Watersheds for each Stream Segment

- Create Watersheds for each Navarro Stream Link Segment. ① Create Watersheds for each segment in the Stream Link network by using the following calculation in the Raster Calculator:

\[
[NAVWAT] = \text{WATERSHED}([NAVFLOWDIR], [NVSTRNET3])
\]
Visualizing Catchments

There are 445 watersheds based on unique stream link segments:

It is easiest to visualize the watersheds by:
- giving each one a unique value,
- turning transparency to 30%
- draping over the hillshade
- and displaying the stream.shp over the catchments.
Add field data...

1. Load the GPS Data of Coho Redds for 2001. Load the Table containing the GPS data by selecting the “Add XY Data” option under the Tools menu.
2. Navigate to and select the `cohoredd01.dbf` file.
3. X Field should be LONG
4. Y Field should be LAT
5. Set Coordinate System to WGS_1984 decimalized degrees by selecting “Edit” and selecting `WGS1984.prj`
Redds...

- Did the spawning redds appear?
- Do they fall on the hydrographic network, or other words, do they line up with the streams? Aren’t spawning grounds in streams?
- How might you go about getting them to line up? This is timeless problem with GPS derived data.
- Short of full editing, we’ll use some freeware tools from SpatialEcology.com to help us out.
We’ll need to export the points as a shapefile. Choose the Layer Export option.

Select the same coordinate system as the data frame, in this case it should be in UTM 10 N NAD27.

Name it `c:\unex\temp\redds.shp`

Add the data to the data frame.
• Load Hawth’s Tools from the Available Toolbars

• Hawth’s Tools are a set of nifty tools developed by Hawthorne Beyer.
Snap Redds to Hydro Network

- Use Hawth’s Tools: Vector Editing Tools: Snap Points to Lines
- ① Examine the data and evaluate and appropriate search radius (in map units)
- ② Use 300m as the search tolerance value, but this means that redds can move up to 300m. Create REDDSNAP shapefile using projected redd events (REDDS), by snapping to STREAM.SHP.
• Was a 300m snap search distance enough to capture all of the redds?
• What is the count of records between the two data sets? Are they the same?
• What about the new field in reddsnap.shp >> [SnapDst]? What was the maximum distance snapped from redd points to the hydrographic network?
Convert the Raster Watersheds To Feature Data

- Use ArcToolbox > Conversion Tools > Raster to Polygon
- What does the Value field represent?
We need to add the Shape_Area Field and Values

- Add a new field to the shapefile, called Shape_Area. Calculate the value using the Pre-Logic VBA code:

![Add Field_dialog]

![ArcGIS_Dialog_Help]

**How to use Visual Basic code to calculate fields based on area, length, perimeter, etc.**

1. These code examples return a value of type 'double', so use them to calculate either an existing field of type 'double' or a new field of type 'double' you've added to the table. For example, you can use these to update the existing area, length or perimeter field you may find in a shapefile's attribute table.

2. Check Advanced. You'll see two empty text entry boxes.

3. Enter one of these four line code examples into the top most box, the one labeled 'Pre-Logic VBA Script Code'. Tip: you can select the code in this help topic, right-click and choose Copy, and then paste it into the box.

   To calculate area:
   ```vb
   Dim Output as double
   Dim parea as Integer
   Set parea = Ishape
   Output = parea.area
   ```

   To calculate length or perimeter (depending on whether the features are lines or polygons):
   ```vb
   Dim Output as double
   Dim pcurve as ICurve
   Set pcurve = Ishape
   Output = pcurve.length
   ```

   To add the x coordinate of points:
   ```vb
   Dim Output as double
   Dim ppoint as IPoint
   Set ppoint = Ishape
   Output = ppoint.x
   ```

   To add the x coordinate of polygon centroids:
   ```vb
   Dim Output as double
   Dim parea as IArea
   Set parea = Ishape
   Output = parea.centroid.x
   ```
• Your field calculation should look something like this:
One last piece of housekeeping...

• You should notice that there are multiple polygons per watershed. How does this happen? Is there a way to fix it?

• Short of hand editing, you can convert the single part features to multi-part features to create a single watershed object. Dissolve can do this...
• Create a dissolved watershed shapefile based on GRIDCODE and summarize the shape area to have a multipart polygon.
• Use Hawth’s Tools to count the number of points (redds >> reddsnapsnap.shp) in polygons (watersheds >> navwatdiss.shp).

• Display the polygons by the number of redds present.

• What do these results look like?
Is there a pattern here?
Now for Timber Harvest Plans..

- Load the NAVTHPS raster data from `c:\unex\geodata\navarro\`.
- What are the Values represented in the data? What are the zeroes?
NAVTHPS

• These data show Timber Harvest Plan data by year for selected years and contain a value of Zero otherwise.

• These THP data have values which denote year.

• Keep in mind that they are not exhaustive; in fact, they only range years ’88-’99.

• How would we determine the area under timber harvest by watershed?

• How about zonal statistics for each NAVWAT watershed?

• Are there caveats to this method?
NAVTHPS $\rightarrow$ NAVTHPAREA

- There is a need to remove cells with a value of Zero. Therefore we use what function in the Raster Calculator?

- We use the SETNULL function →

$$\text{navthparea} = \text{setnull}(\text{navthps} == 0, \text{navthps})$$
How do we tabulate these data by watershed?
We’ll use the Tabulate Area tool in the Spatial Analyst toolbox.
Tabulate the Area of each THP designation in each Watershed

- Select the `navwatdiss.shp` as the zone data set, with GRIDCODE as its zone designation.
- Save as `navwatthp.dbf`
Join the results of THP Area tabulation to the Watersheds

- Right-mouse click on navwatdiss.shp feature and select Join.
- Join the new table (navwatthp.dbf) based on GRIDCODE.
- We’ll need to export this table to maintain the Join procedure.
Calculate Percent Watershed under THP designation

- Export the results of two joined tables (navwatthp to navwatdiss).
- Export this table (navanalysis.dbf).
- Add a field to the exported table.
• Name the new field PCTTHP as type floating point, Precision = 6 and Scale = 2.

**Field precision and scale**

The precision and scale of a field describe the maximum size and precision of data that can be stored in the field. The precision describes the number of digits that can be stored in the field, while the scale describes the number of decimal places for float and double fields. When creating a new field in a geodatabase feature class or table, you can specify the field’s type, precision, and scale. When the field is actually created in the database, the field type may be changed based on the precision and scale values you specify.

Use the following guidelines for choosing the correct field type for a given precision and scale:

- When you create a float, double, or integer field and specify 0 for precision and scale, the geodatabase will attempt to create a binary type field if the underlying database supports it. Personal geodatabases support only binary type fields, and precision and scale are ignored.

- When you create float and double fields and specify a precision and scale, if your precision is greater than 6, use a double; otherwise use a float. If you create a double field and specify a precision of 6 or less, a float field is created in the database. If you create a float field and specify a precision greater than 6, a double field is created.

- If you specify a scale of 0 and a precision of 10 or less, you should be creating integer fields. When creating integer fields, your precision should be 10 or less or your field may be created as double.
Calculate Percent THP

- Calculate the percent of the NAVWAT watersheds that were under THP designation by using the Areas from each Value Year → and dividing by the area of the polygon.

\[
\left( \frac{[\text{VALUE}_{88}] + [\text{VALUE}_{89}] + [\text{VALUE}_{90}] + [\text{VALUE}_{91}] + [\text{VALUE}_{92}] + [\text{VALUE}_{93}] + [\text{VALUE}_{94}] + [\text{VALUE}_{95}] + [\text{VALUE}_{96}] + [\text{VALUE}_{97}] + [\text{VALUE}_{98}] + [\text{VALUE}_{99}] }{\text{SUM}_{\text{Shape}}} \right) \times 100
\]

What if you just wanted data from the nineties?
• Create a graph of reds (points in poly) against PCTTHP to visually inspect if there is a relationship between these two variables.

• ① Select the records in the navanalysis.dbf table with at least one redd.

② Choose the Create Graph option from the Table menu.
• ① Select Scatter Graph.

• ② Choose PntsInPoly as the Y response variable and PCTTHP as the X independent variable.

• ③ Give it a Title, Labels, and a Legend.
This non-linear relationship might not be what you expected, but there are several confounding factors. Can you think of some?
Exercise #4 — Custom Raster Processing in ArcGIS: a Comparison of Model Builder and Visual Basic for Applications

- We will construct a brief, but useful, model in Model Builder to generate a hillshade from the Navarro DEM.
- There are some variable controls within Model Builder, such as inputs, outputs, and parameters.

- However, compared to VBA scripting, some of these options are limited.
- We will also write some code in VBA to perform hillshading on the Navarro DEM, but we will change the layer order and layer transparency to make a more polished output.
• Invoke ArcToolbox

• Right-mouse click and select ‘New Toolbox’.

• Rename to UNEX Toolbox

• Right-mouse click on the UNEX Toolbox and select new >> Model.

• This will create a new Model Builder window, but first:

• Right-mouse click on Model >> Properties. Modify General Tab items to indicate its name, label, and description.
• From the Spatial Analyst Tools, find the HILLSHADE routine in the Surface set.

• Drag the Hillshade Tool to the Model Builder Window.
• Right-mouse click and select Create Variable.

• Select Raster Layer from the list.

• Right-mouse click on the Raster Layer Object and set it as a Model Parameter.
• Double-click on the Hillshade Object to get the Tool’s input parameters.

• Select Raster Layer from the pull-down list to set it (a model parameter) to the input raster.

• Leave the other defaults as they are and select OK.

• Return to the Model Builder Window and set the Output Raster object as a Model Parameter.

• Run the Hillshade Model.
• Use the Effects Toolbar to set the transparency of NAV10M to 40% and drape it over the newly created Hillshade.

• How would you incorporate different input parameters for the hillshade routine (like azimuth and sun angle)?
• What if we wanted to re-order the layers in the Table of Contents and dynamically adjust the transparency?
• Scripting allows customization of the ArcGIS interface, but there are limited options in Model Builder for modifying the graphic environment.
• You can, however, export the underlying model in Model Builder to a scripting language (Python, VBScript, JScript). These scripting languages only provide access to the GeoProcessor environment, not the full suite of ArcObjects. So...
• Visual Basic for Applications is the best method for complete customization in ArcGIS.
• We will create a VBA Macro in ArcMap to run Hillshade on a DEM, move the Hillshade below the DEM, and Set the Transparency of the DEM to 40%
• The end result should be a visual “drape.”
VBA “Drape” Example

- Save the Map Document
- Select Macros from the Tools Pull-down Menu.
- Create New Macro:
  - Name it Drape
- In the VBA Editor, insert the code from the following pages.
Sub Extra_Credit()
    'initialize docs
    Dim pMxDoc As IMxDocument
    Set pMxDoc = ThisDocument
    Dim pMap As IMap
    Set pMap = pMxDoc.FocusMap

    'get the table of contents
    Dim pContentsView As IContentsView
    Set pContentsView = pMxDoc.CurrentContentsView

    'set selected layer to active layer
    Dim pLayer As ILayer
    If Not TypeOf pContentsView.SelectedItem Is ILayer Then Exit Sub
    Set pLayer = pContentsView.SelectedItem

    ' Get the raster from the first layer in ArcMap
    If Not TypeOf pLayer Is IRasterLayer Then Exit Sub
    Dim pRLayer As IRasterLayer
    Set pRLayer = pLayer
    Dim pGeoDs As IGeoDataset
    Set pGeoDs = pRLayer.Raster

    ' Create spatial operators
    Dim pSurfaceOp As ISurfaceOp
    Set pSurfaceOp = New RasterSurfaceOp

    'Continued on next page'
' Create analysis environment
Dim pEnv As IRasterAnalysisEnvironment
Set pEnv = pSurfaceOp

' set output workspace
Dim pWS As IWorkspace
Dim pWSF As IWorkspaceFactory
Set pWSF = New RasterWorkspaceFactory
Set pWS = pWSF.OpenFromFile("c:\unex\temp", 0)
Set pEnv.OutWorkspace = pWS
pEnv.SetCellSize esriRasterEnvValue, 10

' Perform the Hillshade operation
Dim pOutRaster As IRaster
Set pOutRaster = pSurfaceOp.HillShade(pGeoDs, 315, 45, True)

' Add Layer into ArcMap
Dim pRLayer1 As IRasterLayer
Set pRLayer1 = New RasterLayer
pRLayer1.CreateFromRaster pOutRaster
pMap.AddLayer pRLayer1

' set transparency of DEM
Dim pLayerEffects As ILayerEffects
Set pLayerEffects = pLayer
If pLayerEffects.SupportsTransparency Then
    pLayerEffects.Transparency = 40
End If
pMxDoc.ActiveView.Refresh

End Sub
• Drag Command onto Toolbar of your choice.
• Select DEM Layer and Click on **Drape** Macro Command Button.
• Did it work?
• There should be a new RASTER data layer below a semi-transparent DEM.
VBA “Drape” Result
ArcGIS VBA parameters

• Where would you change:
  - Cell Size?
  - Transparency?
• What about running slope instead of hillshade?
• Are there other functions that could be added to this script?
Where to get more help with VBA: